BETA

20th October 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [20/10/18 12:58 PM] with 'Partial Outage'

Issue has been resolved at [20/10/18 01:40 PM]