BETA

19th October 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [19/10/18 02:16 AM] with 'Partial Outage'

Issue has been resolved at [19/10/18 02:21 AM]