BETA

18th October 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [18/10/18 12:06 AM] with 'Partial Outage'

Issue has been resolved at [18/10/18 12:07 AM]