BETA

17th October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [17/10/18 11:01 AM] with 'Partial Outage'

Issue has been resolved at [17/10/18 11:03 AM]