BETA

16th October 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [16/10/18 02:21 PM] with 'Partial Outage'

Issue has been resolved at [16/10/18 02:23 PM]