BETA

16th October 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [16/10/18 10:31 AM] with 'Major Outage'

Issue has been resolved at [16/10/18 10:34 AM]