BETA

16th October 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [16/10/18 05:05 AM] with 'Partial Outage'

Issue has been resolved at [16/10/18 05:06 AM]