BETA

22nd July 2016

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [22/07/16 08:04 PM] with 'Major Outage'

Issue has been resolved at [22/07/16 08:08 PM]