BETA

7th August 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [07/08/19 08:30 AM] with 'Partial Outage'

Issue has been resolved at [07/08/19 09:25 AM]