BETA

15th October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/10/18 02:04 PM] with 'Partial Outage'

Issue has been resolved at [15/10/18 02:05 PM]