BETA

4th May 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [04/05/17 06:58 AM] with 'Major Outage'

Issue has been resolved at [04/05/17 06:59 AM]