BETA

14th October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/10/18 01:07 PM] with 'Partial Outage'

Issue has been resolved at [14/10/18 01:09 PM]