BETA Singapore cluster       Mumbai cluster

5th August 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [05/08/19 01:26 PM] with 'Major Outage'

Issue has been resolved at [05/08/19 01:51 PM]