BETA

14th October 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [14/10/18 02:09 AM] with 'Partial Outage'

Issue has been resolved at [14/10/18 02:12 AM]