BETA

5th August 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [05/08/19 12:37 PM] with 'Major Outage'

Issue has been resolved at [05/08/19 12:55 PM]