BETA

13th October 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [13/10/18 04:53 PM] with 'Major Outage'

Issue has been resolved at [13/10/18 04:55 PM]