BETA

13th October 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [13/10/18 04:01 PM] with 'Partial Outage'

Issue has been resolved at [13/10/18 04:03 PM]