BETA

13th October 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [13/10/18 10:35 AM] with 'Partial Outage'

Issue has been resolved at [13/10/18 10:36 AM]