BETA Singapore cluster       Mumbai cluster

3rd August 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [03/08/19 08:00 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/08/19 08:14 AM]