BETA

13th October 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [13/10/18 03:23 AM] with 'Partial Outage'

Issue has been resolved at [13/10/18 03:26 AM]