BETA

3rd August 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [03/08/19 07:54 AM] with 'Major Outage'

Issue has been resolved at [03/08/19 07:57 AM]