BETA

13th October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [12/10/18 08:03 PM] with 'Partial Outage'

Issue has been resolved at [12/10/18 08:05 PM]