BETA

12th October 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [11/10/18 09:29 PM] with 'Partial Outage'

Issue has been resolved at [11/10/18 09:30 PM]