BETA

4th May 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [04/05/17 06:51 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [04/05/17 06:55 AM]