BETA

3rd August 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [03/08/19 07:26 AM] with 'Major Outage'

Issue has been resolved at [03/08/19 07:27 AM]