BETA

11th October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [11/10/18 03:59 PM] with 'Partial Outage'

Issue has been resolved at [11/10/18 04:00 PM]