BETA

3rd August 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [03/08/19 06:35 AM] with 'Major Outage'

Issue has been resolved at [03/08/19 06:37 AM]