BETA

11th October 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [11/10/18 12:13 PM] with 'Major Outage'

Issue has been resolved at [11/10/18 12:14 PM]