BETA

3rd August 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [03/08/19 05:51 AM] with 'Partial Outage'

Issue has been resolved at [03/08/19 06:04 AM]