BETA

3rd August 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [03/08/19 04:43 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/08/19 04:44 AM]