BETA

3rd August 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [03/08/19 04:27 AM] with 'Major Outage'

Issue has been resolved at [03/08/19 04:28 AM]