BETA

3rd August 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [03/08/19 04:14 AM] with 'Partial Outage'

Issue has been resolved at [03/08/19 04:15 AM]