BETA

10th October 2018

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [10/10/18 11:59 AM] with 'Major Outage'

Issue has been resolved at [10/10/18 12:00 PM]