BETA

3rd August 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [03/08/19 03:32 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/08/19 03:43 AM]