BETA

10th October 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [10/10/18 10:58 AM] with 'Major Outage'

Issue has been resolved at [10/10/18 10:59 AM]