BETA

9th October 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [09/10/18 02:08 PM] with 'Major Outage'

Issue has been resolved at [09/10/18 02:09 PM]