BETA

9th October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [09/10/18 01:49 PM] with 'Partial Outage'

Issue has been resolved at [09/10/18 01:52 PM]