BETA

8th October 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [08/10/18 01:24 AM] with 'Partial Outage'

Issue has been resolved at [08/10/18 01:25 AM]