BETA

7th October 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [07/10/18 08:39 PM] with 'Partial Outage'

Issue has been resolved at [07/10/18 08:40 PM]