BETA

3rd August 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [03/08/19 02:14 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/08/19 02:15 AM]