BETA

7th October 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [07/10/18 03:13 PM] with 'Partial Outage'

Issue has been resolved at [07/10/18 03:15 PM]