BETA Singapore cluster       Mumbai cluster

2nd August 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [02/08/19 10:02 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/08/19 01:09 PM]