BETA

27th July 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [27/07/19 02:17 PM] with 'Major Outage'

Issue has been resolved at [27/07/19 02:23 PM]