BETA

27th July 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [27/07/19 01:08 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [27/07/19 01:09 PM]