BETA

27th July 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [27/07/19 12:58 PM] with 'Major Outage'

Issue has been resolved at [27/07/19 01:06 PM]