BETA

6th October 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [06/10/18 02:14 PM] with 'Partial Outage'

Issue has been resolved at [06/10/18 02:24 PM]