BETA

26th July 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [26/07/19 01:45 PM] with 'Major Outage'

Issue has been resolved at [26/07/19 04:15 PM]