BETA

26th July 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [26/07/19 01:45 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [26/07/19 04:17 PM]