BETA

26th July 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [26/07/19 12:04 PM] with 'Major Outage'

Issue has been resolved at [26/07/19 02:04 PM]