BETA

26th July 2019

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [26/07/19 11:37 AM] with 'Major Outage'

Issue has been resolved at [26/07/19 11:38 AM]